This project is read-only.

GetLogicalDrives() / GetDrives(), Windows 7 64bit / Windows 8 64bit does not show mapped network drives.

Developer
Oct 2, 2012 at 1:56 PM
Edited Jan 13, 2013 at 12:26 PM

After upgrading to Windows 7 64 bit, I noticed that Volume.GetLogicalDrives() and DriveInfo.GetDrives() did not show any mapped drives anymore.

After digging and searching, I stumbled upon this Microsoft article, which solved the issue.

After adding a DWORD registry key: EnableLinkedConnections with a value of 1,
in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
and a reboot of my system, mapped drives appeared again.

Still it is a strange phenomenon since my 32 bit system did not have this key but did show the mapped drives...

Oct 2, 2012 at 3:33 PM
Thank you, very good find.

Sincerely,
Alexandr Normuradov


On 2 October 2012 05:57, Yomodo <notifications@codeplex.com> wrote:
> From: Yomodo
>
> After upgrading to Windows 7 64 bit, I noticed that
> Volume.GetLogicalDrives() and DriveInfo.GetDrives() did not show any mapped
> drives anymore.
>
> After digging and searching, I stumbled upon this Microsoft article, which
> solved the issue.
>
> After adding a DWORD registry key: EnableLinkedConnections in
> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
> and a reboot of my system, mapped drives appeared again.
>
> Read the full discussion online.
>
> To add a post to this discussion, reply to this email
> ([email removed])
>
> To start a new discussion for this project, email
> [email removed]
>
> You are receiving this email because you subscribed to this discussion on
> CodePlex. You can unsubscribe or change your settings on codePlex.com.
>
> Please note: Images and attachments will be removed from emails. Any posts
> to this discussion will also be available online at codeplex.com